linux-l: SiS 80486 PCI Mainboard

Andreas Dücker aduecker at
Do Jul 6 23:59:15 CEST 2000

I tried several chips in the configurations dialog for IDE DMA Chips.
This is a very old i486 pci Mainboard from SiS with the SiS 82C496
The IDE Chip use its own driver. There are Drivers for Wintendo and SCO
No intialization from BIOS for the onboard ide chip
I tried the cmd 640 chipset , with "use dma on default" and also the
generic ide pci.

The kernel dos not recognize any ide chip on ide0... 

PCI devices found:
  Bus  0, device   5, function  0:
    Host bridge: Silicon Integrated Systems 85C496 (rev 2).
      Medium devsel.  Fast back-to-back capable.  Master Capable.  No
  Bus  0, device  11, function  0:
    Ethernet controller: 3Com 3C905 100bTX (rev 0).
      Medium devsel.  IRQ 5.  Master Capable.  Latency=32.  Min
Gnt=3.Max Lat=8.
      I/O at 0x6000 [0x6001].
.... s.o.

 Model=WDC AC310100B, FwRev=32.02S32, SerialNo=WD-WM639
 Config={ HardSect NotMFM HdSw>15uSec SpinMotCtl Fixed DTR>5Mbs
FmtGapReq }
 RawCHS=16383/16/63, TrkSize=57600, SectSize=600, ECCbytes=22
 BuffType=3(DualPortCache), BuffSize=512kB, MaxMultSect=16, MultSect=16
 DblWordIO=no, maxPIO=2(fast), DMA=yes, maxDMA=0(slow)
 CurCHS=1232/255/63, CurSects=19807200, LBA=yes, LBAsects=19807200
 tDMA={min:120,rec:120}, DMA modes: mword0 mword1 *mword2 
 IORDY=on/off, tPIO={min:160,w/IORDY:120}, PIO modes: mode3 mode4 

hdparm -c3 -k1 -X34 d1 uses only 32Bit I/o no dma or multiword transfers
rates at ~4MBs/sec big CPU overhead

any ideas ?

Mehr Informationen über die Mailingliste linux-l